Convercent Call Center - Service Alert
Incident Report for Convercent
Resolved
Thank you for your patience. The issue has been resolved.
Posted Sep 18, 2019 - 08:43 MDT
Update
Thank you for your patience. The issue has been resolved.
Posted Sep 18, 2019 - 08:42 MDT
Identified
Our global local US number, 720-514-4400, is currently experiencing some technical difficulties and is not working at this time. We are aware of the situation and working towards getting it resolved as soon as possible. Thank you for your patience.
Posted Sep 11, 2019 - 18:59 MDT
This incident affected: Convercent Helpline Call Center.