US Shared Line 1-800-461-9330 Not Reachable through Cell Phones

Incident Report for Convercent

Resolved

The issue has been resolved and calls from the Verizon network are connecting as expected.
Posted Jun 04, 2026 - 12:04 MDT

Update

It appears to only be impacting callers using a Verizon phone at this time. The number is reachable via other networks at this time.
Posted Jun 04, 2026 - 09:03 MDT

Investigating

All,
Currently our US Shared number is not reachable through cell phones. We are currently invetigating the issue.
Posted Jun 04, 2026 - 08:43 MDT
This incident affected: Convercent Helpline Call Center.