Call Center Outage

Incident Report for Convercent

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:33 MDT

Update

The call center is coming back online and and now answering calls. We are continuing to monitor the situation closely.
Posted Oct 20, 2025 - 11:58 MDT

Investigating

Our call center is currently is currently experiencing an outage due to the AWS outage. The team is currently investigating.
Posted Oct 20, 2025 - 08:34 MDT
This incident affected: Convercent Helpline Call Center.