Convercent (EU) Email Delivery Impairment - [Service Affected]

Incident Report for Convercent

Resolved

This incident has been resolved, and all recent backed up emails have been cleared. We are working on re-processing any older pending emails from July 1st onwards. Thank you for your patience.
Posted Jul 10, 2025 - 16:29 MDT

Investigating

We are actively investigating an issue impacting email delivery for a subset of emails for the Convercent EU Application. Once we have identified and resolved the cause of this issue, we will provide an update to this status. We apologize for any inconvenience this may have caused.
Posted Jul 10, 2025 - 15:56 MDT
This incident affected: EU Production (SMTP Services).